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What is WinWisdom?
WinWisdom is a pop-up quote-of-the-day application for Windows 3.x.    With it, you can 
receive quotes every time you start Windows.    You can select more quotes at the click of a 
button or print the displayed quote.    You can also minimize WinWisdom to an icon.    That 
way, you can receive additional quotes throughout your Windows session by double-
clicking on the icon.

WinWisdom is designed to be customized.    You can selected your own custom colors, fonts 
and font sizes.    With WinWisdom, you can create files of your own favorite quotes to go 
way beyond the starter file that comes with the application.    Whether you prefer movie or 
TV quotes, political or humorous (Is that the same thing?), or classic quotes of wisdom like 
the starter file, it's completely customizable.

WinWisdom can also be used as a reference.    You can store and lookup quotes by subject 
or author.    The quote list Window allows you to add, edit, delete or print any quote.

WinWisdom uses a file organization that offers a very large quote capacity.    Even with    
Visual Basic limitations, you can still store approximately 5000 subjects or authors, and 
approximately 900 quotes for each subject or author entered.    That's approximately 4.5 
million quotes.    Most likely enough room for your favorites. 

WinWisdom is distributed as shareware.    You may use it free for a 15 day trial period.    If 
you like it and continue to use it you must register your copy with the author.    To register 
your copy, see "How to register" in this help file.

WinWisdom is written in Visual Basic for Windows version 1.0.    The database structure 
used by WinWisdom is managed through VB/ISAM MX - Visual Basic Indexed-Sequential 
Access Method, Multiple indeX version.    Their required legalese follows.

This software was created using VB/ISAM, Copyright Software Source 1991, 1992; all rights 
reserved.    VB/ISAM software may not be used, copied, modified, transferred, or distributed 
except as expressly provided in its software license.    Only licensees of VB/ISAM may create
software that uses any part of VB/ISAM.    Software Source, Fremont, California, USA; 
telephone (510)623-7854.



How to Install WinWisdom
To install WinWisdom, you will need to copy all of the files distributed with WinWisdom to 
the appropriate directories, setup WinWisdom in Program Manager, and add a line to your 
CONFIG.SYSFile.

Install Files
Setup WinWisdom in Program Manager
Change CONFIG.SYS



How to Change Display Settings
WinWisdom is designed to be customized to your preferences.    You can change your 
display colors, fonts, and font sizes.      You can also control whether or not the quote's 
subject is displayed.    If you change any of the default settings, WinWisdom will create file 
WINWIS.INI to keep track of your changes.

Changes are made in the 'Display Options' window.    To display this window, select the 
'Options' menu, then select the 'Display Settings' item (currently the only item on this 
menu).

The 'Display Options' window consists of two drop-down list boxes, one for the font and the 
other for font sizes.    There are four groups of three vertical scroll bars for selecting the 
colors of the main quote window background, the quote text and background, and the field 
headers used in the quote list windows.    There is a single check box for selecting whether 
or not to display the quote subject whenever a quote is displayed on the screen or when 
printed.    And finally, there is a sample quote display to show you what your selections will 
look like. 

You may change any of the items given in this window.    Each change made will cause the 
sample to be updated with your new choices.    When you are satisfied with your new 
display settings, choose the OK button.    To exit without changing the settings, select the 
Cancel button.

NOTE: The colors are selected by manipulating the red, green and blue components of the 
color.    Visual Basic 1.0 doesn't support true 256 colors.    Many colors will be dithered.    For 
text backgrounds, the color displayed will be the nearest solid color.    Many color choices 
will cause strange effects between the form background and the text background.



How to Enter Quotes
To enter quotes into an existing file, choose 'Open' from the 'File' menu.    The file dialog will
display with the currently selected file displayed as the default file to open.    You may press
'OK' to accept the default or select another file and then press 'OK'.    Press 'Cancel' to exit 
without taking action.

To enter quotes into a new file, choose 'New' from the 'File' menu.    The file dialog will 
display for you to enter the filename (no extension) of the new file to create.    Press 'OK' 
when you have entered the filename and are ready to proceed.    Press 'Cancel' to exit 
without taking action.

Selecting 'OK' from either the 'New' or 'Open' file dialogs will then display the quote list 
window.    If this is a new file, the window will display empty.    If you open an existing file 
that has quotes in it, the list screen will display with the first subject in the subject list 
selected and the quotes in that subject displayed in the quote list.      You may toggle 
between display by subject or author.

To enter new quotes, press the 'New' button.    This will display an empty quote editor 
window where you may enter the subject, author, and text of the new quote.    Press 'Save' 
to save the new quote or press 'Cancel' to exit without taking action.    You can also press 
'Print' to print a completed quote even before you save it.

When you press 'Save', the new quote is written to the currently selected file.    The quote 
list will be redisplayed with the subject (or author if the author list is displayed) of the new 
quote selected and the quotes in that subject/author displayed in the quote list. 



How to Print Quotes
There are three ways to print a quote.    Regardless of which method you use, the quote will 
be printed to the default printer setup in Windows.    WinWisdom will also adjust the print to 
fill any page size you have selected.    The font selected in the 'Display Settings' window is 
also used for printing, but the font size will be adjusted depending on the page size.    It will 
print landscape or portrait.    If you do not achieve the desired effect, choose another page 
setup in Windows and print again.

If you wish to print the currently displayed quote from the main quote display window, 
select the 'File' menu and then select the 'Print' menu item.    You can also press CTRL+P 
instead of using the menu options.

To print quotes from a file, choose 'New' from the 'File' menu.    The file dialog will display 
with the currently selected file displayed as the default file to open.    You may press 'OK' to 
accept the default or select another file and then press 'OK'.    Press 'Cancel' to exit without 
taking action.    From the Quote List dialog, look up the quote by subject or author.    Select 
that desired quote by single-clicking on it in the quote list.    To print the selected quote, 
press 'Print'.    Press 'Done' to exit.

If you are entering new quotes or editing existing quotes, you can also press the 'Print' 
button from the quote editor to print a completed quote.



How to Create a Quote File
To create a new quote file, choose 'New' from the 'File' menu.    The file dialog will display 
for you to enter the filename (no extension) of the new file to create.    Press 'OK' when you 
have entered the filename and are ready to proceed.    Press 'Cancel' to exit without taking 
action.    After the file is successfully created an empty quote list window is display so that 
you can enter your own quotes.

Note:    A WinWisdom quote file actually consist of three physical files.    These files will be 
created with your filename and extensions of .ISD, .ISF, and .ISM.    If you copy or move 
your WinWisdom quote files, all three component physical files are required.



How to Register
WinWisdom is shareware, it is NOT public domain.    The registration fee is $10 (US) with a 
free 15-day trial period.    If you intend to use WinWisdom beyond the trial period you must 
register your copy by filling out the form in file REGISTER.TXT from the WinWisdom 
distribution package or providing the same information written on a sheet of paper and 
sending it along with your registration fee to:

Richard Pitts
P.O. Box 963
Alpharetta, GA 30239

Remember to specify your disk size.

With your registration, you will receive the most current version of the program and 
additional quotes.    Your registration supports shareware development. The ability to 
provide future releases depends on your support.



File Menu Commands

New File Command
Open File Command
Merge File Command
Scramble File Command
Pack File Command
Print Quote Command
Exit Command



New File Command
Use this command to create your own WinWisdom Quote file.

When you select this item, you will be asked to enter the directory and filename.    Do not 
enter a file extension.    WinWisdom quote files consist of three physical files with .ISD, .ISF, 
and .ISM extensions.    WinWisdom will automatically create these three files using your 
filename and adding the appropriate extensions.

After the file is successfully created an empty quote list window is display so that you can 
enter your own quotes.



File Open Command
Use this command to select a WinWisdom quote file for additional processing such as 
entering additional quotes, searching for a quote, printing a quote, or just selecting another
file from which to display quotes.

This command does not actually open the file.    In keeping with good Windows practices, 
the quote file is only open during actual use.

Also, whenever you open a file, the quote list window is displayed with the first subject in 
the subject list selected and the quotes in that subject displayed in the quote list. 



File Merge Command
Use this command to combine, or merge, one quote file into another.

This command will display the file dialog to request the file to be merged into the currently 
selected file.    The file from which the quotes are being merged is not modified in any way. 



Scramble File Command
Use this command to change the order of the quotes in the currently selected quote file.

When you add quotes to a quote file, the quotes are stored and subsequently displayed in 
the same order that you enter them.    In many cases, you might enter several quotes on 
the same subject or by the same author.    In order to disperse these quotes throughout the 
file, use the 'Scramble File' command.

Note: Use of this command typically increases the quote file size by 10-20 percent.    To 
reclaim this added space, select the 'Pack File' item from the file menu.

Yes, I know it would have been a good idea to combine the Scramble and Pack functions 
into one, but if I had, what would you have to complain about?



Pack File Command
Use this command after you scramble or when you have made a lot of additions and 
deletions to a quote file.

This command will attempt to reclaim wasted space in the file structure.    It can be run at 
any time, but is most useful after you scramble the file.



Print Quote Command
Use this command to print the currently displayed quote on the main quote display window.

The quote will be printed to the default printer setup in Windows.    WinWisdom will also 
adjust the print to fill any page size you have selected.    It will print landscape or portrait.    
If you do not achieve the desired effect, choose another page setup in Windows and print 
again.



Exit Command
Use this command to terminate WinWisdom.



Options Menu Commands
Display Settings

That's it, there's only one at this time.



Display Settings Command
Use this command to display the 'Display Options' windows to change the display settings 
of WinWisdom.

You can change WinWisdom colors, fonts, font sizes and whether or not the subject 
displays.



WinWisdom Procedures Index
This index lists all WinWisdom Procedure topics.    To learn how to use Help, choose 'Using 
Help' from the Help menu.
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How to register



WinWisdom Commands Index

The index lists all WinWisdom Procedure topics.    To learn how to use Help, choose 'Using 
Help' from the Help menu.

Commands
File Menu Commands
Options Menu Commands



CONFIG.SYS

The CONFIG.SYS file is a system file which specifies which devices to install and which 
installable device drivers to use.    It also contains commands that determine how DOS uses
memory and controls files.



Install Files
Because this program is written using Visual Basic v1.0, it requires the file VBRUN100.DLL.   
It is required to run all Visual Basic v1.0 applications.    If you do not already have a copy of 
this file, you may obtain it from Microsoft, Compuserve or other on-line service, local BBS's, 
or shareware distributors.    In some cases, it may also be provided with the WinWisdom 
distribution package.    Make sure that this file is in either the c:\windows or c:\windows\
system directory.

WinWisdom v3.0 makes use of VB/ISAM.    VB/ISAM requires the file VBISAMMX.DLL and it is 
distributed with WinWisdom.    While you may copy this file into any directory in your DOS 
path or keep it in the same directory containing the WinWisdom executable file, it is best to
place this file in either the c:\windows or c:\windows\system directory.

The following other files are part of the WinWisdom distribution package:
WINWIS.EXE - Program executable
WINWIS.HLP - WinWisdom Help file
WINWIS30.ISM - Starter quote file map component
WINWIS30.ISF - Starter quote file finder component
WINWIS30.ISD - Starter quote file data component
README.TXT - WinWisdom information and instructions
REGISTER.TXT- WinWisdom registration form

The easiest thing to do is to copy all of these files into the c:\windows directory.    Doing this
insures that everything is available to Windows.    If you want to keep WinWisdom in a 
separate directory, set one up and copy the above files into it.

 



Setup WinWisdom in Program Manager
In order to use the WinWisdom pop-up quote-of-the-day feature, you will need to do one of 
the following depending on whether you are running Windows 3.0 or 3.1.

If you have Windows 3.0, do the following:
1.    Using any text editor (Notepad is good for this, SysEdit is better), open the WIN.INI file 
in your Windows directory.
2. Several lines down from the top of the file, you will find a line which begins with 'RUN='.   
This line tells Windows what programs to run after it boots.    Change this line to read:    
RUN=WINWIS.EXE [plus any other startup programs].
3. Save the WIN.INI file.    The next time you start Windows, WinWisdom will pop-up 
displaying your quote-of-the-day.

If you have Windows 3.1 you can do the above, or the following:
1. Open the group that you have designated as your start-up group (by default, the group is
'StartUp').
2. From the File menu, select 'New', then select 'Program Item'.
3. Type WinWisdom as the description (or any thing else you want to call it) and type 
WINWIS.EXE as the command line.
4. If you put WinWisdom in a directory other than the Windows directory, you will need to 
type the directory in the working directory field, and add the directory to the command line 
field.



Change CONFIG.SYS
Due to the use of VB/ISAM, this version of WinWisdom requires a change to your 
CONFIG.SYS file.

Make a backup of this file in case anything goes wrong.    Using any text editor (Notepad is 
good for this, SysEdit is better),    insert the following line into your CONFIG.SYS file:

install=c:\dos\share.exe
This assumes that the SHARE.EXE file resides in the DOS directory of your C: drive.    If not, 
use whatever is appropriate for your system.Save the file.    

Note: In order for this change to take effect, your computer must be rebooted.    To do that, 
exit Windows.    At the DOS prompt, press CTRL+ALT+DEL.


